Emmabuntüs Forum

Support technique => Installation => Conseils => Discussion démarrée par: Patrick le mai 31, 2015, 01:54:16 pm

Titre: [Resolu] Pas d'utilisation du Swap sur Emmabuntüs 3
Posté par: Patrick le mai 31, 2015, 01:54:16 pm
Il arrive parfois que le swap ne soit pas utilisé sur Emmabuntüs 3 suite à une installation.


Pour vérifier qu'il est bien utilisé, regardez avec sysinfo, dans l'onglet "Memory". S'il est indiqué noswap, cela veut dire qu'il n'est pas utilisé :

(http://emmabuntus.sourceforge.net/mediawiki/images/thumb/a/a4/Verification_utilisation_swap_sysinfo.jpg/750px-Verification_utilisation_swap_sysinfo.jpg)


Vous pouvez aussi vérifier avec Gparted, et s'il n'y a pas une petit clé sur la ligne du Swap, celui-ci n'est pas utilisé :

(http://emmabuntus.sourceforge.net/mediawiki/images/thumb/f/fa/Verification_utilisation_swap_gparted.jpg/750px-Verification_utilisation_swap_gparted.jpg)

Une solution pour l'activer, et de modifier le fichier /etc/fstab. Alors pour cela il faut ouvrir une fenêtre terminal en faisant par exemple Touche Windows + T.

Dans cette fenêtre terminal lancez cette commande : sudo geany /etc/fstab puis renseignez votre mot de passe.

Dans l'éditeur de texte, il y a une ligne pour le montage du swap, dans notre exemple :

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=0af90e69-ae86-4ee9-a642-1799e0cb7a8f /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda1 during installation
UUID=0966fdce-4b2f-4e64-95b1-82b1621d8dff none            swap    sw              0       0

La ligne concernant le montage du swap a pourtant le bon numéro UUID (http://fr.wikipedia.org/wiki/Universal_Unique_Identifier) de la partition de Swap mais celui-ci ne se monte pas correctement, alors il faut remplacer le numéro d'UUID par l'adresse logique de notre partition, comme dans l'exemple ci-dessous, par la mise en commentaire de l'avant dernière ligne, et le remplacement par la dernière ligne :

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=0af90e69-ae86-4ee9-a642-1799e0cb7a8f /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda1 during installation
#UUID=0966fdce-4b2f-4e64-95b1-82b1621d8dff none            swap    sw              0       0
/dev/sda1                none            swap    sw              0       0

Après un redémarrage de la machine on peut constater que le swap est correctement monté.