Emmabuntüs Forum
Collectif pour le réemploi des ordinateurs et distribution Linux basée sur Debian

  Accueil -  Tutoriels -  Téléchargements -  Vidéos -  Interviews -  Qui sommes-nous -  Nous contacter -  Soutenir


Installation de Ruby - require : no such file to load(LoadError)

0 Membres et 1 Invité sur ce sujet

habsinn

  • Newbie
  • *
    • Messages: 2
Bonjour. J'ai suivi cette serie d'instructions pour installer ruby v2.1.3, puis sinatra sur emmabuntus : https://lite5.framapad.org/p/2uhNzIMhwU

Au final, quand je clique sur le http://localhost:4567, mon premier programme sur sinatra ne fonctionne pas.

Des suggestions?


Patrick

  • Administrator
  • Hero Member
  • *****
    • Messages: 850
    • Emmabuntüs The distribution sleek, accessible, equitable
Je ne sais pas vous conseiller, car je ne connais pas Ruby, et son installation.

Sinon quelle versions d'Emmabuntus avez-vous installée ? 2 ou 3 ? x32 ou x64 ?

En fonction de cela faite une recherche sur internet avec
pour Emma 2 => Ubuntu ou xubuntu 12.04
pour Emma 3 => Ubuntu ou xubuntu 14.04

install ruby ubuntu 12.04 ou 14.04

voir :
- http://doc.ubuntu-fr.org/rubyonrails
- https://www.digitalocean.com/community/tutorials/how-to-install-ruby-on-rails-on-ubuntu-12-04-lts-precise-pangolin-with-rvm

Je ne peux pas aider les personnes qui veulent se mettre au développement, et il faut prendre contact avec des sites spécialisés sur Ruby.

Le problème de ces outils, c'est qu'ils sont livrés pour des spécialistes, et que les installations peuvent être compliqués.


habsinn

  • Newbie
  • *
    • Messages: 2
Merci pour la reponse et les infos.
Je vais regarder a droite a gauche.

Infos de ma machine (achetee chez Emmaus) :
Linux version 3.2.0-70-generic (buildd@kapok) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #105-Ubuntu SMP Wed Sep 24 19:49:46 UTC 2014


PS : j'avais fait une erreur pour la version de ruby , je suis sur la v1.8.7 .