Emmabuntüs Forum
Collectif pour le réemploi des ordinateurs et distribution Linux basée sur Debian

  Accueil -  Tutoriels -  Téléchargements -  Vidéos -  Interviews -  Qui sommes-nous -  Nous contacter -  Soutenir


déactiver la connexion automatique

0 Membres et 1 Invité sur ce sujet

ideefixe

  • Full Member
  • ***
    • Messages: 241
    • Voir le profil
Bonjour, pendant l'installation d'Emmabuntüs DE 2 1.03, j'ai choisi la connexion automatique au démarrage.

L'inconvénient, c'est que cela bloque le lancement de Chromium. C'était déjà le cas sous HandyLinux.

Comme déactiver la connexion automatique ?

Dans les paramètres, je n'ai pas trouvé.

Faut-il passer par le terminal ?
https://emmabuntus.sourceforge.io/mediawiki/index.php/F.A.Q/fr#Comment_ouvrir_automatiquement_une_session_sur_XFCE_.3F
« Modifié: décembre 15, 2018, 09:41:37 pm par ideefixe »


alain-tux

  • Global Moderator
  • Jr. Member
  • *****
    • Messages: 90
    • Voir le profil
Bonjour Ideefixe

Oui l'idée est bien sur ce wiki. malgré qu'il soit fait pour emmabuntus et non pour emmaDE 2.1.03.mais avant de toucher au fichier "lightdm.conf", il est plus prudent d'en faire une sauvegarde, soit en graphique avec le gestionnaire de fichiers, soit dans un terminal comme cela:sudo cp /etc/lightdm/lightdm.conf /etc/lightdm/lightdm.conf.bakPuis tu fais comme indiqué:sudo geany /etc/lightdm/lightdm.confSauf que toi tu veux supprimer la connexion auto, alors à la ligne:autologin-user=votre_nom_de_connexiontu supprimes  "votre_nom_de_connexion" et surtout tu la commente par un "#" devant, comme cela:#autologin-user=Si tu as une ligne non commentée comme celle ci:autologin-session=trueTu la commente par un "#" comme cela:#autologin-session=trueEnsuite c'est comme le tuto, tu sauvegardes, tu déconnectes la session et tu devrais te retrouver sur la fenêtre du gestionnaire de session (lightdm) ou tu devras entrer ton user et ton mot de passe.
« Modifié: décembre 17, 2018, 05:36:41 am par alain-tux »
PC : Desktop HP Compaq 8200 Elite SFF PC | CPU : i7-2600 | RAM : 4GB | GPU : AMD RV730 PRO [Radeon HD 4650]
OS : emmade4 | Kernel: 5.10
In a world without walls and fences, who needs windows and gates?


Patrick

  • Administrator
  • Hero Member
  • *****
    • Messages: 725
    • Voir le profil
    • Emmabuntüs The distribution sleek, accessible, equitable
Bonjour Ideefixe,

Je confirme que les infos données par Alain-Tux sont les bonnes.

Par contre, je n'ai pas compris pourquoi, et comment cela peut interférer avec le lancement de Chromium ?

Merci de me donner des infos à ce sujet pour voir si cela n'est pas un bug, en essayant de reproduire cela de mon côté.

Amitiés, et bonne journée.


ideefixe

  • Full Member
  • ***
    • Messages: 241
    • Voir le profil
Merci Alain-Tux pour la procédure pour déactiver la connexion automatique.  ;)

Pour Chromium, lorsque je clique sur l'icône dans le dock pour la lancer, il s'ouvre bien mais affiche un message : veuillez entrer votre mot de passe pour déverrouiller le trousseau de connexion. Il faut donc entrer le mot de passe utilisateur (avenir pour l'utilisateur emmabuntus).

Ce message n'apparaitrait plus si l'utilisateur entre le mot de passe à la connexion de sa session.

Le plus simple est d'entrer le mot de passe utilisateur lorsque Chromium le demande.


alain-tux

  • Global Moderator
  • Jr. Member
  • *****
    • Messages: 90
    • Voir le profil
Bonjour Patrick et Ideefix.
Un petit mot vite fait avant d'aller au lit  ;)
Pas un bug d'emmade, plus de chromium.

Pour résoudre ce problème, il faut supprimer les fichiers contenus dans:~.local/share/keyringspuis redémarrer chromium, la il redemande le mot de passe, mais surtout ne rien mettre, juste faire "entrer".Les prochains démarrages devraient être OK.Si besoin de plus d'infos concernant la manipe, je reviens cette nuit.
Bonne journée à vous  ;)
PC : Desktop HP Compaq 8200 Elite SFF PC | CPU : i7-2600 | RAM : 4GB | GPU : AMD RV730 PRO [Radeon HD 4650]
OS : emmade4 | Kernel: 5.10
In a world without walls and fences, who needs windows and gates?