Emmabuntüs Forum

  Accueil -  Tutoriels -  Téléchargements -  Vidéos -  Interviews -  Qui sommes-nous -  Nous contacter -  Soutenir


keyboard num lock problem [SOLVED !]

0 Membres et 1 Invité sur ce sujet

ninos

  • Newbie
  • *
    • Messages: 8
    • Voir le profil
I installed the latest xfce version of Emmanbuntus 32bit in my old laptop yesterday.
It is beautiful and works surprisingly fast and well!

I have a problem with the keyboard, though.
Actually I can't use it, because some of the LETTER buttons print numbers instead of the letters.
I suppose this is a num lock problem.
(for the time being i use the virtual keyboard, but pressing the mouse all the time is rather cumbersome...)

At the keyboard behavior, I clicked
restore num lock state on startup,
but this doesn't work.

Please tell me how I can fix this via the terminal.
I am not tech savvy, just a retired language teacher,
but I love using the terminal.


« Modifié: mai 05, 2021, 10:13:42 pm par ninos »
Emmanuel Ninos
retired teacher


Patrick

  • Administrator
  • Hero Member
  • *****
    • Messages: 709
    • Voir le profil
    • Emmabuntüs The distribution sleek, accessible, equitable
Hi Ninos,

this problem comes from the procedure for identifying a laptop that should not work correctly on your laptop .

In a terminal run this command:

sudo geany /usr/bin/emmabuntus_config.sh
Find these lines of code and comment them out with dieses # in front :

/usr/bin/laptop-detect -v
status=$?
if [ $status -eq 0 ]
then
    numlockx off
    echo "Numeric keypad Off"
elif [ $status -eq 1 ]
then
    numlockx on
    echo "Numeric keypad On"
else
    numlockx off
    echo "Failed to detect keypad type"
    echo "Return code = $status"
fi


ninos

  • Newbie
  • *
    • Messages: 8
    • Voir le profil
I found it lines 217-231

but I don't understand what you mean by:
"comment them out with dieses # in front "
Emmanuel Ninos
retired teacher


Patrick

  • Administrator
  • Hero Member
  • *****
    • Messages: 709
    • Voir le profil
    • Emmabuntüs The distribution sleek, accessible, equitable
Do this on these lines so that they are no longer active :

# /usr/bin/laptop-detect -v
# status=$?
# if [ $status -eq 0 ]
# then
#     numlockx off
#     echo "Numeric keypad Off"
# elif [ $status -eq 1 ]
# then
#     numlockx on
#     echo "Numeric keypad On"
# else
#     numlockx off
#     echo "Failed to detect keypad type"
#     echo "Return code = $status"
# fi

To save the changes save in geany.

To find out if the numlock command works test it by "numlockx on" and "numlockx off" in a terminal and see if that commands the numlock on and off the numeric keypad.


ninos

  • Newbie
  • *
    • Messages: 8
    • Voir le profil
I commented out the lines you told me with #
and saved the code with save,
then I wrote
emmanuel@debian:~$ numlockx off
in the terminal
and
voila!!!
I can now use my keyboard.
I also added the Greek keyboard (ελληνικά).

Thanks a lot Patrick.

I'll be using Emmabuntus on my old 32 bit turbo x laptop.

Emmanbuntus gave it a new chance.
Emmanuel Ninos
retired teacher


ninos

  • Newbie
  • *
    • Messages: 8
    • Voir le profil
is there a short script I can add
so that I don't have to execute the command
numlockx off
  (in the terminal)
every time I turn on my laptop?
Emmanuel Ninos
retired teacher


Patrick

  • Administrator
  • Hero Member
  • *****
    • Messages: 709
    • Voir le profil
    • Emmabuntüs The distribution sleek, accessible, equitable
Add  numlockx off  in the /usr/bin/emmabuntus_config.sh file following these lines:

# /usr/bin/laptop-detect -v
# status=$?
# if [ $status -eq 0 ]
# then
#     numlockx off
#     echo "Numeric keypad Off"
# elif [ $status -eq 1 ]
# then
#     numlockx on
#     echo "Numeric keypad On"
# else
#     numlockx off
#     echo "Failed to detect keypad type"
#     echo "Return code = $status"
# fi


ninos

  • Newbie
  • *
    • Messages: 8
    • Voir le profil
 :)
very easy solution
I've already checked that it works (after reboot)

Thank you Patrick.
Emmanuel Ninos
retired teacher